e-Caisse Home ·
Security and Privacy ·
System Requirements ·
Legal Agreement ·
Technical Support ·
System Requirements

Browsers Supported

To access e-Caisse you will need an Internet browser that supports SSL 128-bit encryption, cookies and tables. We have chosen 128-bit encryption as our standard as it is the strongest publicly-available encryption protection today. On visual browsers, pages will generally look better if the browsers understand style sheets. Our pages look best when your monitor display settings are set to 800 x 600.

Our Home Banking Services can be accessed by:

Note: For Mac users, minimum browser requirements are as follows;

  • 128-bit versions of Netscape: (7.0 or higher)

In order to upgrade your browser to 128-bit encryption, we have provided you with links to the Netscape and Microsoft web sites. If you have a current version of either Microsoft Internet Explorer or Netscape Communicator, the files required to upgrade the encryption to 128 bit are relatively small, quick to download and install. You will need to know the Browser you are using and the version number before attempting to update your system. Look under the Help menu item on your browser menu bar and then choose the menu item "About….." This brings up a screen that shows the version of the browser you are presently using.

Be aware that if you choose to download the full version of either Microsoft Internet Explorer or Netscape Communicator, these are quite large files and depending on the speed of your connection to the internet, may take considerable time to download. You may wish to consider ordering a CD from either Netscape or Microsoft as they both make their browsers available on CD at a nominal cost.

For Technical Assistance, call 1-888-273-3488 or Email Online TechSupport